Fantasy Horde - Orc

3D - CHARACTERS

ALL ASSETS ARE SHARED ONLY FOR LEARNING PURPOSES OR TO BE ABLE TO TEST BEFORE BUYING THE PRODUCT.
IF YOU ARE USING THE ASSETS FOR COMMERCIAL PURPOSES PLEASE BUY IT FROM THE ORIGINAL STORE AND SUPPORT THE DEVELOPER.
Recently added
  • PIDI : XFur Studio 2 - Ultimate Edition - Unity Asset
  • Mummy Pack - Unity Asset
  • UniSky - Unity Asset
  • Modular RPG Heroes Polyart - Unity Asset
  • Snaps Prototype | Construction Site - Unity Asset
  • Snaps Prototype | Buried Memories Volume 2: Serekh - Unity Asset
  • Room Architect - Unity Asset
  • Retro Aesthetics - Unity Asset
  • QuizApp Trivia Template 3.0 - Unity Asset
  • Odin - Inspector and Serializer - Unity Asset
  • MFP: Multiplayer First Person - Unity Asset
  • Motion Matching for Unity - Unity Asset
  • Mobile Speech Recognizer - Unity Asset
  • Mobile Environment Pack - Unity Asset
  • Beast - Unity Asset
  • HELLROT - Unity Asset
  • Golem Pack - Unity Asset
  • GNOME - Unity Asset
  • GIANT SCORPION - Unity Asset
  • Futuristic Soldier 2 - Unity Asset
  • TARBO - Lowpoly Fantasy Village Pack - Unity Asset
  • Epic Music Pack - Unity Asset
  • DWELF - Unity Asset
  • DEMON LORD - Unity Asset
  • DEATH SKULL - Unity Asset
  • DARK ELF - Unity Asset
  • Cron scheduler - Unity Asset
  • CRASC - Unity Asset
  • CERBERUS - Unity Asset
  • Cartoon Nature Pack - Unity Asset
  • Bike Animations Cartoon - Unity Asset

description:

An Orc Army do your Fantasy Game with different acessories, armor and weapons.
Each model has low polygon counts and optimized textures:

-Polycount 1600 tris to 2500 tris (no gear to full gear)
-Textures: 1024x1024 (diffuse, specular and opacity)
-Animation: 28 (Include .max file that allows you create new customized animations)

Ready to use Mecanim.

Please check a Unity preview on our website .

details:

Package contents 66.6 MB
Total file size 66.6 MB
Number of files 54
Releases current ver. 1.271.27
Current released May 13, 2019
Original released May 6, 2011
Supported Unity versions 3.4.0 or higher
Package has been submitted using Unity 3.4.0, 5.3.0, and 5.6.5 to improve compatibility with the range of these versions of Unity
Support website Publisher website